网站首页 文章专栏 ubuntu 安装composer 解决php依赖问题
ubuntu 安装composer 解决php依赖问题
编辑时间:2017年7月12日 17:07 作者:赵彦昌 浏览量:123

直接进入正题

一, ubuntu14.04 安装PHP5.6


使用ppa增加源:
$ sudo apt-get install python-software-properties
$ sudo add-apt-repository ppa:ondrej/php
$ sudo apt-get update
$ sudo apt-get install -y php7.0 php7.0-mysql php7.0-curl php7.0-json php7.0-cgi
然后可以查看php版本:
php -v
关于php5.4--php5.6版本

$ sudo apt-get install python-software-properties
$ sudo add-apt-repository ppa:ondrej/php
$ sudo apt-get update
$ sudo apt-get -y install php5.6 php5.6-mcrypt php5.6-mbstring php5.6-curl php5.6-cli php5.6-mysql php5.6-gd php5.6-intl php5.6-xsl php5.6-zip
查看php7的扩展

sudo apt-cache search php7-* 

PHP安装好后,我们就可以安装composer 了


二、composer 的 安装


$curl -sS https://getcomposer.org/installer | php  

$chmod +x composer

$mv composer.phar /usr/local/bin/composer

$composer -V
Composer version 1.4.1 2017-03-10 09:29:45


总结:不知道 ,我的安装好后,运行composer install 总是报错,好像composer.json 写的不对,最后,降到 1.2.4 好了,关于降级 ,可以在github 直接 composer.phar


来说两句吧
最新评论